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THE INTERFACE

The Graphical User Interface
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Figure 1 - The Graphical User Interface
A brief description of each element is given below:

Title Bar

The Title Bar displays the name of the application and if a file or
files is open the name of the active file.

Menus

The Menus give the user access to all the functionality of
SolarLink.

Toolbar

The Toolbar gives the user shortcuts to commonly used
functions.

Calendar Bar

The Calendar Bar is used to navigate through the data in an
active file.
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Status Bar

Provides feed back to the user about which Com Port is
selected, which measurement scale is selected and if CAPS,
NUM or SCRL lock is on.

Temperature Information Box

This information box gives feedback on the location of cursor, if it
IS active.

General Information Box

This information box gives feedback on the device the data was
downloaded from.

View Mode

This tab strip allows the user to choose how to view the
information downloaded from the device.

The Toolbar

FHEcTIWVFE &a|?

Figure 2 - The Toolbar

The Toolbar as explained earlier gives the user shortcuts to
commonly used functions. These are explained below; from left
to right:

Open
See page 7.

Save
See page 8.

Print
See page 8.

Toggle Collector Plot

This allows the use to toggle the plot line for the Collector On and
Off.

Toggle Tank Plot
This allows the use to toggle the plot line for the Tank On and Off.
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Toggle Cursor Mode

This allows the user to toggle the Cursor Mode On and Off. With
Cursor mode on, the Temperature Information Box gives the user
feedback on the current location of the cursor.

Toggle Autoscale

This function rescales the axis so that the plots are completely
visible and as large as possible. Each day is Autoscaled
individually, so the scale will change as the user navigates
through the data.

Import Data
See page 10.

Monitor Mode
See page 10.

Configure Device
See page 10.

About
See page 14.

The Status Bar

Comm Port: 1 EEentigrade MUM |CAPS |SCHL
Figure 3 - The Status Bar

The panels in the Status Bar give the user feedback on the status
of the application and the PC. The panels are described below;
from left to right:

Comm Port: x
Where x is the selected Comm Port.

Temperature Measurement

This panel will display either Centigrade or Fahrenheit. The user
can change this setting in the Preferences.

NUM Lock

If the panel text is greyed out then the NUM Lock is off. If the text
is black then the NUM Lock is on.
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CAPS Lock

If the panel text is greyed out then the CAPS Lock is off. If the
text is black then the CAPS Lock is on.

SCRL Lock

If the panel text is greyed out then the SCRL Lock is off. If the
text is black then the SCRL SCRL is on.

The Menus

The File Menu

Open... Ctrl+0

Save Az, Chl+ad

Export... Clrl+E
Frint Setup...
Frint... Ctrl+P

C:hbest ksl
tezt kel

29 daysz.tzl
2dapznew. kzl

Exit Chrl+

Figure 4 - The File Menu

Open

The Open menu enables the user to open a data file, which has
been previously downloaded from a device and saved to the hard
disk of the computer. This option may also be selected from the

Toolbar using the = icon. By default, only files with a .TSL
extension will be displayed.

Close

This option will close the current graphic window. SolarLink will
prompt the user to save any information, which has changed
since the last save. If the user chooses to ignore this prompt
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then data or set-up changes may be lost.

Save As

The Save option enables the user to write data to the hard disk of
the computer. This option may also be selected from the Toolbar

using the [ icon. Having saved downloaded data, the user may
retrieve it using the Open command. By default, files will be
saved with a .TSL extension. If the data was previously saved,
SolarLink will replace the file; otherwise the user will be prompted
to enter a filename.

Export

This option enables the user to export data to a standard CSV
(Comma Seperated Values) file, which may then be imported to
Microsoft® Excel or Lotus 123® spreadsheet software.

Print Setup

This option invokes the standard Windows® print set-up
dialogues. For help on setting up a printer, please refer to either
the Windows® help system or the Windows® user manual.

Print

This option enables the user to make a hardcopy of the current
graphical display using a printer. This option may also be

selected from the Toolbar using the & icon. This option will
invoke the standard Windows® print utilities. For help on
configuration of printers, please refer to the Windows® help
system or manuals.

Most Recently Used Files

The most recently used files list will contain the last 4 files to be
opened by the user. It provides a quick and convenient method of
reopening a file. Simply left click on the desired filename and the
file will be reopened. If no files have previously been opened,
then this list will be empty.

Exit

This option enables the user to exit SolarLink. If any files have
been changed and not saved, then the user will be prompted to
save them before the program is terminated.
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The View Menu

v Toolbar
v Statuz Bar
v Calendar Bar

Align Calendar Bar » [EEOTNR:
v Align Right

Figure 5 - The View Menu

Toolbar

This option enables the user to either hide or display the toolbar.
If this option is marked with a +, then the toolbar is displayed.
The state of the option is toggled each time this option is
selected.

Status Bar

This option enables the user to either hide or display the Status Bar. If
this option is marked with a w, then the Status Bar is displayed. The
state of this option is toggled each time the option is selected.

Calendar Bar

This option enables the user to either hide or display the Calendar
Bar. If this option is marked with a w, then the Calendar Bar is
displayed. The state of this option is toggled each time the option is
selected.

Align Calendar Bar

This option allows the user to choose on which side of the screen
the Calendar Bar is docked. If Align Left is marked with a w,
then the Calendar Bar will be docked on the left hand side of the
screen. If Align Right is marked with a », then the Calendar Bar
will be docked on the right hand side of the screen.

The Comms Menu

Cornmns

Configure Unit... Chl+l

Import Data...  Chl+
Monitar Mode  Chil+

Figure 6 - The Comms Menu
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Configure Unit
This option allows the user to configure the solar controller from
the PC. This option may also be selected from the Toolbar using

the P icon.

Import Data

This option enables the user to import information from the solar
controller using the supplied RS232 lead. This option may also

: *
be selected from the Toolbar using the = icon.

Monitor Mode

This option enables the user to view the current temperatures and
status at an interval defined in the Preferences. This option may

also be selected from the Toolbar using the 9 jcon.

The Options Menu

Optionz

FPreterences... Chrl+F
Minimize to System Tray

Englizh
German

Figure 7 - The Options Menu

Preferences
There are three pages of preferences:

Gereral I Conme | Coers |
~ Earsal Setliog:

T AT
v Masdmes Spplicstion on Stslup

[# Piird Diste on Priceoot

[¥ &humys Dbeorals

f* Cemipgieds
" Fakuanhet

Figure 8 - Preferences, General Tab
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This page of preferences allows the user to:

Flat Toolbar
Choose between the clasical toolbar or the contemporary flat
toolbar.

Maximize Application on Startup
Always maximize SolarLink on startup.

Print Date on Printout
Chooses whether or not to print today’s date on the the printouts.

Always Autoscale
Choose whether or not to Autoscale the charts by default.

Choose Y axis scale
Choose between Centigrade or Fahrenheit.

Comnn Pt Seting:

Careen Part: |Comin 1I] Test I

=l
Foribar Mesde Intereal Flﬁ‘__l

o | oo | e |

Figure 9 - Preferences, Comms Tab

Comm Port

This option enables the user to specify the communications port
to which the monitoring device is attached. If the user tries to
select a communication port, which is already in use or does not
exist, then a warning message shall be displayed when the user
tries to download or connect to their solar controller. If the user
has connected a device to their PC they can use the Test button
to verify they have selected the correct Comm Port.

Monitor Mode Interval

This option lets the user set an interval in seconds, between
each download from the unit when it is in Monitor Mode. The
lowest value is 1 second and the highest value is 60 seconds. It
is strongly recommended that the user does not use a value
lower than 10 seconds.
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Tempersture Siaph Coloor:

Artiee Cupson hd - Craladl |

~Ereigy Gizph Colnus

Actize Cursal '—] - Cielol |

i . Dl |
o cod | |

Figure 10 - Preferences, Colour Tab

Colours
Allows the user to pick their own default colour scheme and save
it. Any new data that is downloaded will be in the newly selected
colours.

Minimize to System Tray

This action allows the user to use the Monitor Mode function
without having to keep the full application active. Once the user
selects the function the application will appear as an icon in the
System Tray as shown in Figure 11.

| NR=® 1420

Sytem Tray lcon
Figure 11 - Minimize to System Tray

To start the Monitor Mode function left click once on the icon. The
Monitor Mode dialog will be shown. The interval set in the
Preferences will be used for the interval between successive
downloads. The Monitor Mode dialog will stay on top of all other
windows while it is active. To restore the application, cancel the
Monitor Mode Dialog and right click once on the icon.

Language

This option allows the user to choose between English or
German.
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The Window Menu

Window

LCascade

Tile Harizontally
Tile Vertically
Arrange lcons

v 1 test tsl

Figure 12 - The Window Menu

Cascade

This option enables the user to cascade multiple graphic
windows. This is a standard Windows® option, please refer to the
Windows® User Manual for further information.

icon.

Tile Horizontally

This option enables the user to tile multiple graphic windows
horizontally. This is a standard Windows® option, please refer to
the Windows® User Manual for further information.

Tile Vertically

This option enables the user to tile multiple graphic windows
vertically. This is a standard Windows® option, please refer to the
Windows® User Manual for further information.

Arrange Icons

This option enables the user to arrange the icons within the main
display window. This is a standard Windows® option, please
refer to the Windows® User Manual for further information.

Window List

This option displays a list of all open data windows. The
currently active window is marked with a . The user may change
the active window by using the mouse to click left upon the
desired window. This is a standard Windows® option, please
refer to the Windows® User Manual for further information.
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The Help Menu

About, . |

Figure 13 - The Help Menu

The About dialog tells the user the version number and gives
them some contact information.
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Figure 14 - About Dialog

This option may also be selected from the Toolbar using the '@
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COMMUNICATIONS

Connecting A Device

A monitoring device may be connected to each spare
communications port of the PC. All connections should be made
using the cables supplied with the devices.

MasterLink supports the standard communication ports COM1 to
COM16.

To use a particular communication port, the user should connect
the device to the required port and then select the port from
within SolarLink using the Options — Preferences —
Comms menu.

If the selected communications port is already in use or is not
present, then an error message will be displayed whenever the
user tries to download or connect to their Thermomax unit.

Importing Data

To import data, the user should select the Comms — Import
Data option. After having selected this option, a dialogue as
shown in Figure 15 will be displayed. From this dialogue, the
user may then select the type of import required.

Download Data x|

Murmber of Daps Awvailable 32

— Diownload Optionz
& i Day
7 Days
= Al Days
£ Select no. of days l 32
Impaort LCancel

Figure 15, Comms —2 Import

Import 1 Day

This option will import the temperatures recorded today. As the
information is being downloaded, a status window will display the
progress.

Import 7 Days

This option will import the last seven days worth of temperatures.
As the information is being downloaded, a status window will
display the progress.
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Import All Days

This option will import all the data stored in the connected device.
As the information is being downloaded, a status window will
display the progress.

Select no. of days

This option will import the number of days selected by the user,
as in Figure 15, the last 32 days data.
As the information is being downloaded, a status window will

display the progress.

Communication Status

As the information is being imported, a status dialogue will be
displayed on the screen. Figure 16 illustrates a typical example
of this dialogue.

Download Progress

Day 16 of 32

]

Figure 16 - Communications Status Dialog

If SolarLink is unable to communicate with the connected device,
it will time-out after a period of 3 seconds and display a message
indicating that communications have timed out.

Monitor Mode
Monitor mode is a method of importing the current channel values
every. The interval is user definable in the Preferences.
To enter monitor mode, select the Comms —» Monitor Mode
option. This will cause the monitor mode dialogue to appear, as
illustrated in Figure 17.
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onitor Mode S

Callector Temperature Iq?
Return Temperature |29
Tank 1 Temperature |32
Tank 2 Temperature Ifo
Pump 1 Statuz IEIn
Pump 2 Statuz quf
Pump 3 Status Qff
Aux 1 Status |[|ff
Aux 2 Statuz Off

W aiting. ..

. Lancel |

Figure 17 - Monitor Mode Dialog

Monitor Mode - Temperature Values

These are the actual values downloaded from the connected
device. Any channels which are unavailable on the connected

device will read ‘—'.

Monitor Mode - Pump and AUX Status

These are the actual status of the Pump and Auxilary relays on
the connected device.

Monitor Mode - Communication Status

The communications status indicates the status of the
communications during Monitor Mode. When a set of values
have been downloaded the blue bar will go back to zero and start
growing. Once it reaches its full size, another set of values will
be downloaded.
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GRAPHICS

The Calendar Bar

— Contral
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Figure 18 - The Calendar Bar

The Calendar Bar is located on the right side of the main display
and is illustrated in Figure 18. This enables the user to easily
navigate through the data, for the currently selected record. To
jump to a particular day or month, the user should left click with
the mouse on the desired button. Note: SolarLink will disable
buttons, which have no associated data.
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Displaying Information

The data may be displayed in 3 different formats. These formats
are detailed in the following sections.

Temperature Graph Mode

Whiessim o SolasLink - [28 faystsl]

Figure 19 illustrates an example of the Temperature Graph Mode.
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Figure 19 - Temperature Graph

The graphic mode enables the user to view the temperature
channels for one day on the same axis. The user may view the
temperature in either Centigrade or Fahrenheit. The channel
labels are displayed in the same colour as their corresponding
channel beside the y-axis.
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Table View Mode
Figure 20 illustrates an example of the Temperature Table View
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Figure 20 - Table View

This view displays the actual temperature data for the current day
in table format. The temperature can be view in either Centigrade
or Fahrenheit.
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Energy Graph Mode

Figure 21 illustrates an example of the Energy Graph Mode.

Figure 21 - Energy Graph

The graphic mode enables the user to view the energy data. The
user may view the temperature in either Centigrade or
Fahrenheit. The channel labels are displayed in the same colour
as their corresponding channel beside the y-axis.
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